Rails4のインストール

OS X(10.8.2)、Ruby1.9.3系で試した。

まずRails4は githubのリポジトリを指定してやる必要があるのでGemfileだけつくる

$ vim Gemfile

以下のように書く

source :rubygems
gem 'rails', github: 'rails/rails'

そしてインストール

$ bundle install

入ったようだ

$ gem list

*** LOCAL GEMS ***

activerecord-deprecated_finders (0.0.2)
arel (3.0.2)
atomic (1.0.1)
builder (3.1.4)
bundler (1.2.3)
erubis (2.7.0)
hike (1.2.1)
i18n (0.6.1)
json (1.7.6)
mail (2.5.3)
mime-types (1.19)
minitest (4.4.0)
multi_json (1.5.0)
polyglot (0.3.3)
rack (1.4.4)
rack-test (0.6.2)
rake (10.0.3)
rdoc (3.12)
rubygems-bundler (1.1.0)
rvm (1.11.3.5)
sprockets (2.8.2)
sprockets-rails (2.0.0.rc1)
thor (0.16.0)
thread_safe (0.1.0)
tilt (1.3.3)
treetop (1.4.12)
tzinfo (0.3.35)

$ rails -v
Rails 4.0.0.beta